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LibreOffice options

This section covers some of the settings that apply to all the components of LibreOffice and are of 
interest to users of Impress. Other general options are discussed in Getting Started Guide Chapter 
2 Setting Up LibreOffice.

1) Go to Tools > Options (LibreOffice > Preferences on a Mac) on the menu bar to open 
the Options dialog. The list on the left-hand side of the Options dialog varies depending on 
which component of LibreOffice is open. The illustrations in this chapter show the list as it 
appears when Impress is open.

2) Click the expansion marker (+ or triangle) by LibreOffice on the left-hand side. A list of 
subsections drops down.

Figure 1: Options – LibreOffice – User Data dialog

Note
The Revert button has the same effect on all pages of the Options dialog. It resets 
the options to the values that were in place when you opened LibreOffice.

User Data options
Impress uses the first and last name stored in the User Data to fill in the Created by and Modified 
by fields in document properties, the optional Author field used in the footer of a presentation, and 
the name associated with comments. If you want your name to appear, then do the following:

1) In the Options dialog, click LibreOffice > User Data (Figure 1).

2) Fill in the Address form with your details and/or delete any existing incorrect information.

Print options
In the Options dialog, click LibreOffice > Print (Figure 2) to set the print options that suit your 
default printer and your most common printing method.
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You can change these settings at any time, either through the Options dialog or during the printing 
process. See Chapter 10 Printing, E-mailing, Exporting, and Saving Slide Shows in this guide for 
more information about the printing options available.

Figure 2: Options – LibreOffice – Print dialog

Color options
In the Options dialog, click LibreOffice > Colors to specify colors used in LibreOffice documents. 
You can select a color from a color table, edit an existing color, or define new colors. These colors 
are stored in your color selection palette and are then available in all components of LibreOffice.

You can also define colors within Impress by going to Format > Area on the menu bar, or through 
the Line and Filling toolbar, but those colors will not be available to other components of 
LibreOffice.

Figure 3. Options – LibreOffice – Colors dialog
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Appearance options
In the Options dialog, click LibreOffice > Appearance to specify which items are visible and the 
colors used to display various elements of the user interface.

The only option specific to Impress (and Draw) is the color of the grid points. Scroll down in the 
page until you find Drawing/Presentation. To change the default color for grid points, click the 
down-arrow by the color and select a new color from the pop-up dialog.

If you wish to save your color changes as a color scheme, click Save, type a name in the Save 
scheme dialog, then click OK.

Figure 4. Options – LibreOffice – Appearance dialog

Figure 5: Options – LibreOffice Impress – General dialog
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Choosing options for Impress

In the Options dialog, click the expansion marker to the left of LibreOffice Impress on the left-
hand side. A list of subsections for Impress drops down (Figure 5).

General options
In the Options dialog, click LibreOffice Impress > General (Figure 5) to specify the general 
options for presentation documents.

Text objects

• Allow quick editing – if selected, you can edit text immediately after clicking a text object. 
If deselected, you must double-click to edit text. In a presentation, you can also activate the 

text editing mode using the Allow Quick Editing icon  on the Option toolbar (Figure 6).

Figure 6: Options toolbar

• Only text area selectable – specifies whether to select a text frame by clicking the text. In 
the area of the text frame that is not filled with text, an object behind the text frame can be 
selected. In a presentation, you can also activate this mode using the Select Text Area 

Only icon  on the Option toolbar.

New document

• Start with Wizard – specifies whether to activate the Presentation Wizard when creating a 
new presentation using File > New > Presentation on the menu bar.

Settings

• Use background cache – specifies whether to use the cache for displaying objects on the 
master page. This speeds up the display. Deselect this option if you want to display 
changing contents on the master page.

• Copy when moving – if selected, a copy is created when you move an object while 
holding down the Ctrl key. The same will apply for rotating and resizing the object. The 
original object will remain in its current position and size.

• Objects always moveable – specifies that you want to move an object with the Rotate 
tool enabled. If this option is not selected, the Rotate tool can only be used to rotate an 
object.

• Unit of measurement – determines the unit of measurement used for presentations.

• Tab stops – defines the spacing between tab stops.

Presentation

• Always with current page – specifies that you always want a presentation to start with the 
current slide. When this option is not selected, a presentation always starts with the first 
page.

• Enable remote control – specifies that you want to enable Bluetooth remote control while 
Impress is running. Deselect this option to disable remote control.
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Compatibility
The settings in this area are valid for the current document only.

• Use printer metrics for document formatting – specifies that printer metrics are applied 
for printing and also for formatting the display on the screen. If this option is not selected, a 
printer independent layout will be used for screen display and printing. If you set this option 
for the current document and then save the document, for example, in an older binary 
format, this option will not be saved. If you later open the file from the older format, this 
option will be set by default.

• Add spacing between paragraphs in the current document – specifies that Impress 
calculates the paragraph spacing exactly like Microsoft PowerPoint. Microsoft PowerPoint 
adds the bottom spacing of a paragraph to the top spacing of the next paragraph to 
calculate the total spacing between both paragraphs. Impress utilizes only the larger of the 
two spacings.

View options
In the Options dialog, click on LibreOffice Impress > View (Figure 7) to specify the available 
display modes. By selecting an alternative display, you can speed up the screen display while 
editing your presentation.

Figure 7: Options – LibreOffice Impress – View dialog

• Rulers visible – specifies whether to display the rulers at the top and to the left of the work 
area.

• Snap Lines when moving – specifies whether to display guides when moving an object. 
Impress creates dotted guides that extend beyond the box containing the selected object 
and which cover the entire work area, helping you position the object. You also can use this 

function using the Helplines While Moving icon  on the Options toolbar (Figure 6) if a 
presentation is open.

• All control points in Bézier editor – displays the control points of all Bézier points if you 
have previously selected a Bézier curve. If this option is not selected, only the control 
points of the selected Bézier points will be visible.

• Contour of each individual object – Impress displays the contour line of each individual 
object when moving this object. This option enables you to see if single objects conflict with 
other objects in the target position. If you do not select this option, Impress displays only a 
square contour that includes all selected objects.

Grid options
In the Options dialog, click LibreOffice Impress > Grid (Figure 8) to specify the grid settings for 
Impress. Using a grid helps you determine the exact position of your objects. You can also set this 
grid to line up with the snap grid.
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If you have activated the snap grid, but wish to move or create individual objects without snap 
positions, keep the Shift key pressed to deactivate this function for as long as needed.

Figure 8: Options – LibreOffice Impress – Grid dialog

Grid

• Snap to grid – activates the snap function. If this option is selected, but you want to move 
or create individual objects without snapping to the grid, press the Shift key to deactivate 
Snap to grid whilst moving the individual object. You can also use the Snap to Grid icon

 on the Options toolbar (Figure 6).

• Visible grid: displays grid points on the screen. These points will not display or print as 
part of a presentation.

Resolution

• Horizontal – defines the unit of measure for the spacing between grid points on the X-axis.

• Vertical – defines the grid points spacing in the desired unit of measurement on the Y-axis.

• Synchronize axes – specifies whether to change the current grid settings symmetrically. 
The resolution and subdivision for the X and Y axes remain the same.

Subdivision

• Horizontal – specify the number of intermediate spaces between grid points on the X-axis.

• Vertical – specify the number of intermediate spaces between grid points on the Y-axis.

Snap

• To snap lines – snaps the edge of an object being dragged to the nearest snap line when 
you release the mouse. You can also define this setting by using the Snap to Snap Lines 

icon  on the Options toolbar (Figure 6).

• To the page margins – specifies whether to align the contour of the graphic object to the 
nearest page margin. The cursor or a contour line of the graphics object must be in the 
snap range. In a presentation, this function can also be accessed with the Snap to Page 

Margins icon  on the Options toolbar.
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• To object frame – specifies whether to align the contour of the graphic object to the border 
of the nearest graphic object. The cursor or a contour line of the graphics object must be in 
the snap range. In a presentation, this function can also be accessed with the Snap to 

Object Border icon  on the Options toolbar.

• To object points – specifies whether to align the contour of the graphic object to the points 
of the nearest graphic object. This only applies if the cursor or a contour line of the graphics 
object is in the snap range. In a presentation, this function can also be accessed with the 

Snap to Object Points icon  on the Options toolbar.

• Snap range – defines the snap distance between the mouse pointer and the object 
contour. LibreOffice Impress snaps to a snap point if the mouse cursor is nearer than the 
distance specified.

Snap position

• When creating or moving objects – specifies that graphic objects are restricted vertically, 
horizontally or diagonally (45°) when creating or moving them. You can temporarily 
deactivate this setting by pressing the Shift key.

• Extend edges – specifies that a square is created based on the longer side of a rectangle 
when the Shift key is pressed before you release the mouse button. This also applies to an 
ellipse (a circle will be created based on the longest diameter of the ellipse). When this 
option is not selected, a square or a circle will be created based on the shorter side or 
diameter.

• When rotating – specifies that graphic objects can only be rotated within the rotation angle 
that you selected. If you want to rotate an object outside the defined angle, press the Shift 
key when rotating. Release the key when the desired rotation angle is reached.

• Point reduction – defines the angle for point reduction. When working with polygons, you 
might find it useful to reduce their editing points.

Print options
In the Options dialog, click on LibreOffice Impress > Print (Error: Reference source not found) to 
specify print settings for a presentation. See Chapter 10 Printing, E-mailing, Exporting, and Saving 
Slide Shows for more information about the options available.

Figure 9: Options – LibreOffice Impress – Print dialog
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Quality

• Default – specifies that you want to print in original colors.

• Grayscale – specifies that you want to print colors as grayscale.

• Black & white – specifies that you want to print the document in black and white.

Print

• Page name – specifies whether to print the page name.

• Date – specifies whether to print the current date.

• Time – specifies whether to print the current time.

• Hidden pages – specifies whether to print the pages that are currently hidden from the 
presentation.

Page options

• Default – specifies that you do not want to further scale pages when printing.

• Fit to page – specifies whether to scale down objects that are beyond the margins of the 
current printer so that they fit on the paper in the printer.

• Tile pages – specifies that pages are to be printed in tiled format. If the pages or slides are 
smaller than the paper, several pages or slides will be printed on one page of paper.

• Brochure – select this option to print the document in brochure format. You can also 
decide if you want to print the front, the back or both sides of the brochure.

• Front – select this option to print the front of a brochure.

• Back – select this option to print the back of a brochure.

• Paper tray from printer settings – determines that the paper tray to be used is the one 
defined in the printer setup.

Customizing the user interface

Menu font
If you want to change the menu font from that supplied by LibreOffice to the system font for your 
operating system:

1) Go to Tools > Options > LibreOffice > View on the menu bar.

2) Select Use system font for user interface and click OK.

Menu content
You can customize the menus in Impress by adding and rearranging items on the menu bar, 
adding items to menus, and other changes.

1) Go to View > Toolbars > Customize or Tools > Customize on the menu bar to open the 
Customize dialog (Figure 10).

2) Make sure the Menus page is open.

3) In the Save In drop-down list, select whether to save this customized menu in LibreOffice 
Impress or for a presentation.

4) In the section LibreOffice Impress Menus, select from the Menu drop-down list the menu 
that you want to customize.
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5) To customize the selected menu, click on the Menu or Modify buttons. You can also add 
commands to a menu by clicking on the Add button. These actions are described in the 
following sections. Use the up and down arrows next to the Entries list to move the 
selected menu item to a different position.

6) When you have finished making all your changes, click OK to save them.

Figure 10. Customize dialog – Menus page

Figure 11: New Menu dialog
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Creating new menus
To create a new menu:

1) On the Menus page of the Customize dialog, click New to open the New Menu dialog 
(Figure 11).

2) Type a name for your new menu in the Menu name box.

3) Use the up and down arrow buttons to move the new menu into the required position on 
the menu bar.

4) Click OK to save. The new menu now appears on the list of menus in the Customize 
dialog. It will appear on the menu bar itself after you save your customizations.

5) After creating a new menu, you need to add some commands to it, as described in “Adding 
menu commands” on page 15.

Modifying existing menus
To modify an existing menu:

1) On the Menus page of the Customize dialog and select the menu you want to modify from 
the Menu drop down list.

2) Click Menu to open a list of modifications: Move, Rename, Delete. Only Move is available 
in the list. Rename and Delete are not available for the default menus within LibreOffice.

3) To move a menu (for example File), select Menu > Move to open the Move Menu dialog 
(Figure 12).

4) Use the up and down arrow buttons to move the menu into the required position.

5) To move submenus (for example File | Send), select the main menu (File) in the Menu list 
and then, in the Menu Content section of the Customize dialog (Figure 10), select the 
submenu Send in the Entries list and use the arrow keys to move it up or down in the 
sequence.

6) Click OK to save your changes and close the dialog.

Figure 12: Move Menu dialog

Creating keyboard shortcuts
In addition to renaming a menu, you can specify a keyboard shortcut that allows you to select a 
menu command when you press Alt key plus an underlined letter in a menu command.

1) Select a menu or menu entry.

2) Click Modify in the Customize dialog (Figure 10) and select Rename.

3) Add a tilde (~) in front of the letter that you want to use as an accelerator. For example, to 
select the Save All command by pressing Alt+V, enter Sa~ve All.

14 Setting Up and Customizing Impress



Note
Be careful when creating new keyboard shortcuts. In the example above, if the File 
menu is not already open, then pressing Alt+V opens the View menu. If another 
menu is open, Alt+V might activate some other command.

Adding menu commands
You can add commands to menus and to menus you have created.

1) On the Menus page of the Customize dialog (Figure 10), select the menu in the Menu list 
and click Add.

Figure 13: Add Commands dialog

2) In the Add Commands dialog (Figure 13), select a category and then the command, and 
click Add. The dialog remains open, so you can select additional commands.

3) When you have finished adding commands, click Close.

4) In the Customize dialog, use the up and down arrow buttons to arrange the commands in 
your preferred sequence.

5) Click OK to save your changes and close the dialog.

Modifying menu entries
In addition to changing the sequence of entries on a menu or submenu, you can add submenus, 
rename or delete the entries, and add group separators.

1) On the Menus page of the Customize dialog (Figure 10), select the menu in the Menu list 
you want to modify.

2) Select an entry in the Entries list under Menu Content.

3) Click the Modify button and choose the required action from the drop-down list of actions. 
Most of the actions are self-explanatory. Begin a group adds a separator line after the 
highlighted entry.
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Customizing toolbars
You can customize toolbars in several ways, including choosing which icons are visible, and 
locking the position of a docked toolbar, as described in Getting Started Guide Chapter 1, 
Introducing LibreOffice. This section describes how to create new toolbars and add other icons 
(commands) to the list of those available on a toolbar.

Customize toolbars
1) Go to View > Toolbars > Customize or Tools > Customize on the menu bar, or right-click 

in an empty area on the toolbar and select Customize Toolbar from the context menu, to 
open the Customize dialog (Figure 14).

Figure 14. Customize dialog – Toolbars page

2) Make sure the Toolbars page is open.

3) In the Save In drop-down list, select whether to save this customized toolbar for Impress or 
for a selected presentation.

4) In the LibreOffice Impress Toolbars section, select from the Toolbar drop-down list the 
toolbar that you want to customize.

5) Click Toolbar on the right to display a drop-down list of options for customizing the toolbar.

6) Select the option you want to use from the context menu. Icons Only is the default setting 
for toolbars.

7) To display or hide commands, select or deselect the checkboxes in Commands in the 
Toolbar Content section.

8) To change the position of commands on a toolbar, select a command and click the up and 
down arrows to the right of the list.

9) When you have finished customizing a toolbar, click OK to save your changes and close 
the dialog.
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Creating new toolbars
To create a new toolbar:

1) Go to View > Toolbars > Customize or Tools > Customize on the menu bar, or right-click 
in an empty area on the toolbar and select Customize Toolbar from the context menu, to 
open the Customize dialog (Figure 14).

2) Make sure the Toolbars page is open.

3) Click New to open the Name dialog (Figure 15).

4) Type a name for the new toolbar and select from the Save In drop-down list where to save 
this new menu for Impress or for a selected document.

Figure 15: Name dialog for new toolbars

5) Click OK and the new toolbar now appears on the list of toolbars in the Customize dialog. 
After creating a new toolbar, you have to add some commands to it, as described below.

Adding toolbar commands
To add commands to a new toolbar or to customize an existing toolbar:

1) Go to View > Toolbars > Customize or Tools > Customize on the menu bar, or right-click 
in an empty area on the toolbar and select Customize Toolbar from the context menu, to 
open the Customize dialog.

2) Make sure the Toolbars page is open  (Figure 14).

3) Select the toolbar from the Toolbar drop down list.

4) Click Add to open the Add Commands dialog (Figure 13 on page 15) and is the same 
dialog used for adding commands to menus (“Adding menu commands” on page 15).

5) Select a Category and then a Command from the relevant list.

6) Click Add. The Add Commands dialog remains open, so you can select additional 
commands.

7) When you have finished adding commands, click Close. If you insert an item which does 
not have an associated icon, the toolbar will display the full name of the item; see 
“Choosing icons for toolbar commands” below on how to choose an icon for a toolbar 
command.

8) On the Customize dialog, use the up and down arrow buttons to arrange the commands in 
your preferred sequence.

9) When you have finished making changes, click OK to save and close the dialog.

Choosing icons for toolbar commands
Toolbars usually have icons and not words to indicate commands, but not all commands have 
associated icons.

1) Select the command and click Modify and select Change icon on the context menu to 
open the Change Icon dialog (Figure 16).

2) Scroll through the available icons and select the one you want to use.

3) Click OK to assign it to the command.
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Figure 16: Change Icon dialog

Note
To use a custom icon, create it in a graphics program and then import it into 
LibreOffice by clicking Import on the Change Icon dialog. Custom icons must be 
16×16 or 26×26 pixels in size and cannot contain more than 256 colors.

Customizing keyboard shortcuts
The Appendix to this guide lists the default keyboard shortcuts supplied with Impress. You can 
change these defaults or add new shortcuts. You can assign shortcuts to standard Impress 
functions or your own macros and save them for use with Impress only or with the LibreOffice 
suite.

Caution

Be careful when reassigning predefined shortcut keys used in your operating system 
or LibreOffice. Many key assignments are universally understood shortcuts, such as 
F1 for Help, and are always expected to provide certain results. Although you can 
easily reset the shortcut key assignments to LibreOffice defaults, changing some 
common shortcut keys can cause confusion, frustration and possible data loss or 
corruption, especially if other users share your computer.

Example shortcut key
For example, suppose you wish to assign a shortcut key to easily insert a duplicate slide in your 
presentation. You could assign the Insert key as a logical shortcut for this purpose, as described 
below.

1) Go to View > Toolbars > Customize or Tools > Customize on the menu bar, or go to on 
the menu bar, or right-click in an empty area on the toolbar and select Customize Toolbar 
from the context menu to open the Customize dialog.

2) Make sure the Keyboard page is open (Figure 17).

3) As the shortcut key assignment is only relevant with Impress and not LibreOffice, select 
Impress in the upper right corner of the dialog.

4) Select Insert in the Category list and Duplicate Slide in the Function list.

5) Select the shortcut key Insert in the Shortcut keys list and click Modify.

6) Click OK to accept the change. Now the Insert key will insert a duplicate slide immediately 
after the currently selected slide.
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Figure 17: Customize dialog – Keyboard page

Note

All existing shortcut keys for the currently selected Function are listed in the Keys 
selection box. Since there was no currently assigned shortcut for the Insert > 
Duplicate Slide function the Keys list was empty. If it had not been, and you wished 
to reassign a shortcut key combination that was already in use, you would first have 
to Delete the existing key.

Shortcut keys not available for reassignment are greyed out in the listing on the 
Customize dialog, for example F1 and F10.

Saving changes
Changes to the shortcut key assignments (and other configurations) can be saved in a keyboard 
configuration file for use at a later time. This allows you to create and apply different configurations 
as the need arises.

1) After making your keyboard shortcut assignments, click Save in the Customize dialog.

2) In the Save Keyboard Configuration dialog that opens, select All files from the Save as 
Type list.

3) Enter a name for the keyboard configuration file in the File name box, or select an existing 
file from the list. If you need to, browse to find a file from another location.

4) Click Save. A confirmation dialog will appear if you are about to overwrite an existing file; 
otherwise there will be no feedback and the file will be saved.
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Loading saved keyboard configurations
To load a saved keyboard configuration file and replace your existing configuration, click Load in 
the Customize dialog and then select the configuration file from the Load Keyboard Configuration 
dialog.

Resetting shortcut keys
To reset all of the keyboard shortcuts to their default values, click Reset in the Customize dialog. 
Use this feature with care as no confirmation dialog will be displayed and the defaults will be set 
without any further notice or user input.

Running macros from key combinations
You can also define shortcut key combinations that will run macros. These shortcut keys are strictly 
user-defined and no macro shortcut keys are supplied with LibreOffice. For information on macros, 
see the Getting Started Guide, Chapter 13 Getting started with macros.

Adding functions with extensions

An extension is a package that can be installed into LibreOffice to add a new function.

Although individual extensions can be found in different places, the official LibreOffice extension 
repository is at http://extensions.libreoffice.org/. Some extensions are free of charge; others are 
available for a fee. Check the descriptions to see what licenses and fees apply to the ones that 
interest you.

Figure 18: Extension Manager dialog
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Installing extensions
To install an extension, follow these steps:

1) Download the extension and save it anywhere on your computer.

2) In LibreOffice, go to Tools > Extension Manager on the menu bar to open the Extension 
Manager dialog (Figure 18).

3) Click Add and a file browser window opens. Find and select the extension you want to 
install and click Open. The extension begins installing. You may be asked to accept a 
license agreement.

4) When the installation is complete, the extension is listed in the Extension Manager dialog.

Tip
To get extensions that are listed in the repository, you can open the Extension 
Manager and click the Get more extensions online link.

Note
To install a shared extension, you need write access to the LibreOffice installation 
directory.

Using extensions
This section describes some of the more important and popular extensions to Impress. In each 
case, you need to first install the extension as described in the previous section.

Presenter Console
This is bundled with most installations of LibreOffice and provides extra control over slide shows 
(presentations). For example, the Presenter Console has the ability to see the next slide in the 
presentation, slide notes, and a presentation timer, while the audience only sees the slide currently 
being displayed. The Presenter Console displays the elements in three easily changeable views:

• First view displays the current slide, including the effects, and the next slide.

• Second view shows notes for the speaker in large, clear, and scalable type, plus the 
current and next slide.

• Third view is a slide sorter view with the slide thumbnails.

The Presenter Console is only available for use if you have a second display connected to your 
computer. See Chapter 9, Slide Shows for more information about using the Presenter Console.

Note
The Presenter Console works only on an operating system that supports multiple 
displays and only when two displays are connected (one may be the laptop built-in 
display).

Professional Template Pack II
Provides more than 120 templates for Writer, Calc, and Impress. Available in several languages. 
After you have installed this extension, you will find the templates in the Template Manager, 
reached from File > New > Templates on the menu bar.

Presentation Minimizer
Reduces the file size of the current presentation. Images are compressed and data that is no 
longer needed is removed. Can also optimize the image quality size. Presentations designed for 
screen or projector do not require the same high quality as presentations designed for print.

Adding functions with extensions 21


	Copyright
	Contributors
	Feedback
	Acknowledgments
	Publication date and software version

	Note for Mac users
	LibreOffice options
	User Data options
	Print options
	Color options
	Appearance options

	Choosing options for Impress
	General options
	Text objects
	New document
	Settings
	Presentation
	Compatibility

	View options
	Grid options
	Grid
	Resolution
	Subdivision
	Snap
	Snap position

	Print options
	Quality
	Print
	Page options


	Customizing the user interface
	Menu font
	Menu content
	Creating new menus
	Modifying existing menus
	Creating keyboard shortcuts
	Adding menu commands
	Modifying menu entries

	Customizing toolbars
	Customize toolbars
	Creating new toolbars
	Adding toolbar commands
	Choosing icons for toolbar commands

	Customizing keyboard shortcuts
	Example shortcut key
	Saving changes
	Loading saved keyboard configurations
	Resetting shortcut keys
	Running macros from key combinations


	Adding functions with extensions
	Installing extensions
	Using extensions
	Presenter Console
	Professional Template Pack II
	Presentation Minimizer



